v1 cases take longer than expected

Incident Report for Digicust

Resolved

This incident has been resolved.
Posted May 06, 2026 - 15:55 UTC

Investigating

We are currently investigating this issue.
Posted May 06, 2026 - 14:05 UTC
This incident affected: Case Processing.