E-Mail upload not working

Incident Report for Digicust

Resolved

This incident has been resolved.
Posted Jul 16, 2025 - 10:26 UTC

Investigating

We are currently investigating this issue.
Posted Jul 16, 2025 - 08:21 UTC
This incident affected: Email upload.